You are here

application start after bootLoader | Cypress Semiconductor

application start after bootLoader

Summary: 9 Replies, Latest post by Bob Marlowe on 24 Sep 2016 06:58 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
damian_aus's picture
User
20 posts

Hi, i'm having a first time play with the bootloader on PSoC 4 - loving it, fantastically easy.

Only issue i'm experiencing is that after successfully programming the new firmware over UART (via bootloader host), the new application doesn't start automatically and i have to perform a manual reset.

Is there something i'm missing?

kind regards,

Damian 

user_1377889's picture
User
10106 posts

Did you provide your own bootloader or are you using a CY8CKIT-04942xx prototyping kit with a pre-programmed bootloader?

 

Bob

damian_aus's picture
User
20 posts

Hi Bob, yes i'm using the CY8kit-042-ble pioneer kit.

For the bootloader in my firmware i'm using the bootloader component v1.50. Hope that answers your question.

Damian

user_1377889's picture
User
10106 posts

Not quite.

You need 2 projects: A bootloader project and a bootloadable project. Can you please post both complete projects, so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting files.

 

Bob

 

damian_aus's picture
User
20 posts

Hi Bob, thanks - here is the bootloader, and the bootloadable application

regards,

Damian

user_1377889's picture
User
10106 posts

I cannot open the bootloader_app, can you please retry creating the workspace.

 

Bob

damian_aus's picture
User
20 posts

my appologies, i had to copy these from another PC and i guess i didn't quite do it correctly. Please try these and let me know if you have any problems -,

regards,

damian

damian_aus's picture
User
20 posts

Hi, does anybody have any ideas on this, i could really use some help.

 

regards,

Damian

 

apsteffe_1867601's picture
User
7 posts

CY8CKIT-04942xx,  problem with the UART_TX01 project.  I added the Bootloadable component, removed the LCD component, and changed the Baud rate to 31250 (standard for MIDI), edited main.c to create an endless loop transmitting 3 characters every second.   Programming is successful (takes about 10-15 seconds).  But Verify fails with cannot read data from device.  The debugger cannot find the target device.

user_1377889's picture
User
10106 posts

The CY8CKIT-049 42xx has no debugging capabilities. Programming this kit can only be done using the bootloader host program. You will have to use a miniprog3 when wanting to debug. Have a look into the documentation at c:\Programme(x86)\Cypress where you find entries for every kit you successfully installed.

 

Bob

Log in to post new comments.