You are here

Use of the Cypress Microsoft Certified USB UART Driver | Cypress Semiconductor

Use of the Cypress Microsoft Certified USB UART Driver

Summary: 6 Replies, Latest post by HIMA on 31 Mar 2015 12:12 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Gari's picture
Cypress Employee
21 posts

I saw that these wonderful certified drivers take care of the few issues that were found with the Windows standard USBerial drivers.
The drivers though have two inf files, and there is no direct information on how to use them. I am thus posting these steps:

1. There are two inf files associated with the device: CypressUsbAndBus.inf and CypressSerial.inf. The device when comes up the first time, attach it to CypressUsbAndBus.inf file. This file has the PID_VID details of the device. These drivers are signed for VID_PID: 04b4_0003/0005/0008. During development to use these drivers with a Windows OS, you need to use these PID_VID only, as you cannot use an unsigned driver (When you change the inf file the signature is lost). So in your device, please program the PSoC with PID_VID 0003/0004/0005_04b4. The example project has a VID_PID of 04b4_F232. Do take care that you cannot use these PID_VID combination for your end product without Cypress's approval.

2. After the device is bound to CypressUsbAndBus.inf file, the device is recognized as Cypress USB to SERIAL adapter in the device manager. A New Hardware Found pop-up window appears again. Use the second inf file CypressSerial.inf file. The device will enumerate as a Cypress Serial device, with an associated COM port number alloted by the drivers and OS.

Remember to use the right inf file. Windows 7 , amd64 - 64 bit system, x86 is 32 bit system. Rest is trivial. :)



twistx77's picture
52 posts

 These was exactly what I needed. Than you so much. 

Gari's picture
Cypress Employee
21 posts

 Hey Everyone,

I saw that for Windows 8 and Windows 8.1 you cannot use the PID 0003 for the USB-UART example project for PSoC. It will be good if you use the PID as 0008 instead and follow the steps given abvove to bind your device.

Also, do remember that these drivers can be used just for developmental purposes, you will need to get your  own driver signature and buy your PID to be able to produce and distribute the product.



maxdamage's picture
47 posts

Hi everyone,

I've encountered a similar problem to this that my driver wont be updated with the .inf files generated with the project.

I found two .inf files in different folders inside the project folder the first is at Generated_Source\PSoC3\USBFS_cdc.inf and the second at codegentemp\USBFS_cdc.inf. I tried assigning both folders and get nothing. what could i do ?


philiptimson's picture
1 post

 I'm using the PSoC 5 for development hardware.  We cannot get Win7 to recognize the USBUART on a new machine.  I tried the following (and many other installs) with no success: 


  • Downloaded Microsoft Certified USB UART Driver:
    • Installed CypressDriverInstaller.exe
  • Read and followed Use of the Cypress Microsoft Certified USB UART Driver
  • Device manager > USBUART > Properties > Update Driver > Browse for driver software on your computer
    • C:\Program Files (x86)\Cypress\Cypress USB-Serial Driver\DriverBinary\CDC_Driver\bin\win7\x64
    • => Windows was unable to instlal your USBUART
    • C:\Program Files (x86)\Cypress\Cypress USB-Serial Driver\DriverBinary\CDC_Driver\bin\win7\x86
    • => Windows was unable to instlal your USBUART

I'm getting the impression that I am not even close to the solution or using the Microsoft Certified USB UART Driver for what it was intended. 

Could you steer me in the right direction?

user_14586677's picture
7646 posts
HIMA's picture
Cypress Employee
169 posts



Are you facing the issue when pointing to the .inf file in the Project Generated folder also or only with the Microsoft certified Cypress drivers?




Log in to post new comments.