You are here

USB BOOTLOADER | Cypress Semiconductor

USB BOOTLOADER

Summary: 5 Replies, Latest post by Bob Marlowe on 11 Nov 2013 03:52 AM PST
Verified Answers: 1
Last post
Log in to post new comments.
sungd's picture
User
2 posts

 I had read the document AN73503 which is about USB Bootloader. And also download the project, but after the component update, the project has servals errors.

 
Is the verson of component don’t compatible each other? What should I do? My Software is PSoc Creater 2.2,  Need I update the software to PSoc Creater 3.3.
user_119377051's picture
User
866 posts

Hi sungd

Maybe you are using KitProg, PSoC5 version

Can you find PSoC3 version?

I would be search it and show you later.

user_119377051's picture
User
866 posts

AN73503, PSoC3 design is contain 2 projects

Bootloader and Bootloadable

Of course, those must use same device.

You have to ensure that.

user_1377889's picture
User
10803 posts

I compiled (after updating the project) with Creator 3.0 without any errors.

 

Bob

 

sungd's picture
User
2 posts

Thank guys help. I haven't  a Mini Prog3. My board is CY8CKIT-030 PSoc 3 Development kit. Hope someone can give the mini prog3. And I can update my software to Creator 3.0, Let me try it

user_1377889's picture
User
10803 posts

You do not need a miniprog 3 to program a -030Kit.

There are two (2) USB connectors on the board, one is for programming and debugging, the other is connected directly to the PSoC3. I suggest you to have a look into the schematics.

When using a bootloader you will have to use the second USB-port to update the chip with the new bootloadable.

Sounds a bit complicated  .

There is something else I remember (Hopefully some other helper will jump in here) I have in mind that projects using the second USB as bootloader should run at 3.3V but I may be totally wrong with that.

 

Bob

Log in to post new comments.