You are here

target device not getting powered | Cypress Semiconductor

target device not getting powered

Summary: 13 Replies, Latest post by PSoC Rocks on 08 Nov 2012 03:00 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
megh's picture
User
10 posts

 I'm using a cy8ckit-001 development kit. The device being used is cy8c3866axi-040. I selected the correct device in the device selector window and connected the miniprog3. In the select debug target window, I can see miniprog but i cant see the psoc3 device. I have connected the development kit to the power supply. I thought my jumper settings may not be correct. Can anyone tell me how to make the right VDD, VDDIO, VDDD and VDDA settings? I think the device is not being powered coz that's what Psoc Programmer says. In the miniprog, the status LED gets turned on, but the target power LED is turned off. The miniprog settings I've made are

protocol: SWD

power: 3.3V

acquire mode: reset

freq: 3.2 MHz

connector: 10 pin

What should I do?

Please help.

Thanks.

 
user_1377889's picture
User
10803 posts

Did you try to power the Kit-001 with the accompanying power-supply ? Is the green power LED then lighting?

 

Bob

megh's picture
User
10 posts

 I connected the kit to the 12 V power supply adapter. When the VDD is switched to 3.3V the green LED on the board is turned on. But the Programmer still says that the device is not powered.

user_1377889's picture
User
10803 posts

Are you using the SWD-port?

 

Bob

megh's picture
User
10 posts

 I've connected the miniprog to the USB port of my PC and the miniprog to J5( PROG) on the Psoc3. Should I be making any other connections?

megh's picture
User
10 posts

 In the system editor, the operating conditions for VDD, VDDio, etc was 5.0V. But I've selected 3.3V while setting the miniprog. Should I change the values for VDD, VDDIO to 3.3V??

user_1377889's picture
User
10803 posts

The miniprog3 must be connected to SWD with the ribbon cable.

 

Bob

 

 

user_1377889's picture
User
10803 posts

Just checked the schematics, J5 is right.

 

Bob

user_1377889's picture
User
10803 posts

You now should de-select in the options for debugging that you power your board with the miniprog.

 

Bob

megh's picture
User
10 posts

 how do i do that? I selected power as external in the miniprog settings but the device is still not being detected

I've attached two pictures of the settings I've made

Attachments: 
megh's picture
User
10 posts

 this is the other image

Attachments: 
Log in to post new comments.