You are here

Self Test Fails | Cypress Semiconductor

Self Test Fails

Summary: 3 Replies, Latest post by Consulting Guy on 06 Feb 2012 11:47 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
Consulting Guy's picture
User
9 posts

Group,

 

Just received a CY8CKIT-030 today. The quick step guide shows to plug in the USB cable and watch the pot vary the voltage. My problem, the board first performs a self test. It gets to the LED test and continues to blink LED 3 and 4. No more action on the board.

I looked for documentation about the self test, and could not find it. Any help possible on what to do now ?

Marc

Consulting Guy's picture
User
9 posts

Group,

No word yet from customer support or forum. Should I just return the development board ?

Can anyone help ?

 

Marc

U2
uday's picture
Cypress Employee
569 posts

 Hi there, its just that the firmware that was loaded is a self test firmware that is used at the factory to test if everything is working fine. The board should be perfectly alright. You dont need to return the kit to cypress. Please insert the CD that comes with the the kit and install the software. It also installs the firmware that is assocaited with the kit you can load that firmware in to the kit from PSoC Creator and get started with the kit. Please go to this page to get started with PSoC3, http://www.cypress.com/?id=2232&tabID=38386

Consulting Guy's picture
User
9 posts

Group,

What I found out was :

1. Two out of the four LEDS are wired up, so only two blink during the self test.

2. The development board was not "factory programed" with the ADC program, as shown on the quickstart guide.

3. When I programed the board for the example ADC program, it now worked O.K.

 

Marc

Log in to post new comments.