You are here

'PWM_Timer_STATUS': undefined identifier | Cypress Semiconductor

'PWM_Timer_STATUS': undefined identifier

Summary: 6 Replies, Latest post by rufusthedog on 26 Jun 2012 08:56 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
rufusthedog's picture
User
3 posts

Newbie here,

I'm going though the first example in "My First FIve PSoC 3 Designs" and I receive this error.

"'PWM_Timer_STATUS': undefined identifier"

I downloaded the associated source files and receive the same error.

Any help would be greatly appreciated.

Thanks in advance,

Bryan

 

user_1377889's picture
User
10803 posts

It would be best, if you upload your project here to have us a look at.

To do so:

Build -> Clean Project

File -> Create Workspace Bundle (minimal)

and then upload the residing zip-archive with your post.

 

Did you use in Creator 2.0 the "Build -> Buils Project" command? Changed any name??  

 

Bob

user_14586677's picture
User
7648 posts

 

To add to Bobs comments,

 

Components have names, and the attached API generator uses those names as

the object name. So in this example, the PWM name being PWM_1, if you wanted

to call the start function you would write PWM_1_Start(). This is done so API generator

can handle multiple components, of same type, and generate APIs specific to each

component.

 

I compiled this project w/o error. There is a define in the project,

 

So did you change name of PWM_1 to PWM_......?

 

Regards, Dana.

#define PWM_1_STATUS (*(reg8 *) PWM_1_PWMHW__SR0)

rufusthedog's picture
User
3 posts

I simply downloaded the example from Cypress and it failed to compile.  Needless to say I'm still learning "C" so I'm sure it's something simple.

user_1377889's picture
User
10803 posts

Rename in the schematic PWM_1 to PWM_Timer, then it will compile.

Double-click on the component and change the name, cursor is already in the name-field.

 

Bob

user_1377889's picture
User
10803 posts

By the way: Would you be so kind to post the address here from which you uploaded the project, I'd like to have an error like that correctes soon.

Bob

rufusthedog's picture
User
3 posts

My bad, the source code from the website didn't have the schematic, I made schematic and the error.

Thank you all for the help.

 

Bryan

Log in to post new comments.