You are here

Problem in example1 of application note AN66627 Rev.*D | Cypress Semiconductor

Problem in example1 of application note AN66627 Rev.*D

Summary: 8 Replies, Latest post by mam on 27 Mar 2013 03:48 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
mam
user_216401431's picture
User
18 posts

 Good after noon everyone

i am  facing a problem in application note AN66627

when i programmed PSoC with example 1. it does not calculate speed of fan connected to it. and also it does not generating any pwm pulse on p0.5 of uc.

i have also connect p0.5 to oscilloscope to confirm that it is generating any output or not. but it is not generating any pulse.

i am confused about this. may be fan controller component is not working properly.

is anyone use it successfully?

i am using kit CY8CKIT-001 and PSOC3 plateform. and 4-pole dc fan (12v,0.40A, 45dBA noise)

suggest some solution to this problem.

 

user_1377889's picture
User
10803 posts

What is your interface between the fan and your board, since the PSoC is not able to drive 400 mA

 

Bob

mam
user_216401431's picture
User
18 posts

yes i know that. that's why i have given power to fan  from another 12v supply, i just connect pwm and tech signal of fan directly to psoc. as these signal are digital in nature  and can be connect to any UC directly.

user_14586677's picture
User
7648 posts

Thats odd, in example 1 of this ap note I do not see any p 0.5 connections comitted.

 

 

 

mam
user_216401431's picture
User
18 posts

thank you sir

but this diagram belongs to  Themal management expansion board kit CY8CKIT-036 example 1 for host kit-001. but i am talking about Psoc3 and PSoc5 intelligent fan controller (application note 66627 by  Jason Konstas).

link for this is 

http://www.cypress.com/?rID=49077

 

but this is not a problem any more . we can connect output of bank  of fan controller to any port to which we want. main problem is that fan controller output is given to any port but when we connect this signal to fan it is not controlling speed of fan.

i also use the output of that pin to oscillscope to see whether it is generating any pulse or not. but there is no pulse

at that pin

means fan controller either does not generate pwm pulse of particular frequency and duty cycle or any other thing that i am unable to find.

 

 

then what is the problem?

i want to know about that

why it is not generating any pulse. or i am monitoring in a wrong way

to see the output of that pin. i simply connect 1 wire from that pin to positive terminal of osciloscope and gnd of osciloscope is connected to gnd of processor module. am i right?

 

i also connect this signal to fan but there is no change in speed  of fan as i am changing duty cycle via switchs

user_14586677's picture
User
7648 posts

I went to that link, opened all 5 projects, cannot see a single project with P_0_5 connected to anything ?

 

Archive the project you are working with and post it.

 

Regards, Dana.

mam
user_216401431's picture
User
18 posts

 may be that project is modified by cypress.

i am uploading that project i am working with. 

port pin is not problem. problem is why it is not generating a pwm pulse?

mam
user_216401431's picture
User
18 posts

 and application note is also attached with this post. please see it.

mam
user_216401431's picture
User
18 posts
Log in to post new comments.