You are here

Failed USB Driver install for PSoC 3 Firstouch | Cypress Semiconductor

Failed USB Driver install for PSoC 3 Firstouch

Summary: 2 Replies, Latest post by Vasu_Drexel on 05 Jun 2012 12:31 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Niems's picture
1 post

After much searching around, I have been forced to look for help.

I have installed all the software included with the kit, but after plugging in the kit via USB, my computer detects it as an 'Unknown Device', and the driver installation fails.


I have tried windows update, searching for a driver to manually install, all without luck. It consistently shows up as un unknown device in Device Manager, no matter how many times it tried to install, even after trying every available USB port.

The problem also occured on a completely different computer running the same operating system.


Windows 7 32-bit

Dell XPS M1530

Core 2 T9300

3 Gb Ram

PSoC 3 FirstTouch Starter Kit


Any help greatly appreciated!

user_611219's picture
41 posts


Make sure you have the latest PSK3 software, which you can find here:


I have attached a gif showing the driver, when correctly installed.

Vasu_Drexel's picture
8 posts

I seem to have the same problem as the original post except that it was working a few hours ago and then just stopped working. I saw the driver location and the correct file is still there. But windows says it can't find the driver though I point it to the correct folder. I reinstalled the software with no luck.

Any thoughts? Thanks.


Log in to post new comments.