You are here

programming with miniprog3 | Cypress Semiconductor

programming with miniprog3

Summary: 4 Replies, Latest post by hli on 14 Jan 2014 02:56 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
KMoe's picture
4 posts

Hello everyone!

I am trying to use the MiniProg3 to program my PSoC3, CY8C3245PVI-134.  I have the programmer settings set to 5-pin SWD programming at 3.3V, Auto-Dectection on, and Power cycle mode with a clock speed of 1.6MHz.  My programmer software is the most recent version.  I have had nothing but problems.

First off, when told to program the chip, the Auto-detect doesn't work so I have to manually set the device chip.  Even after this, it never powers up the device, fails, and most times disconnects from the computer, causing the programmer software to occasionally crash.  I've even tried programming through the  Creator IDE, same thing happens.  

My next try was to attempt the Reset programming mode and having the device externally powered, I have a little more success with that.  Occasionally the Auto-detect works, and it will erase the device and attempt to program the flash, but everytime it is followed by this Failure message:

FAILED! SWD respond packet contains Failed status!

Anyone have any idea what is going on?  I've tried contacting Tech Support via both email and phone and they are just too slow to respond.  I'm going to try to program with the JTAG next.

Ah, one more thing.  I went back to a PSoC 1 device that I know can be programmed with a MiniProg1, when attempting to program it with the MiniProg3, which claims to be able to do so, I get the same disconnection or just failure to program problems, thinking it just might be a bad programmer I bought another one, but all my problems persist.  Please help!

KMoe's picture
4 posts

 Well, I have now tried programming this PSoC3 using JTAG with the 10-pin connector and SWD with both 5 and 10-pin connectors.  These are the following failures I get from both:

JTAG:  FAILED! Timeout of SPC polling. Lost communication with chip (Status = 0x80)

SWD:  FAILED! SWD respond packet contains Failed status!

Can someone please tell me what's going on?  Is there something in software I'm missing?  Some component in Creator that I am not aware of?

vvsk's picture
Cypress Employee
25 posts


I wanted to point out a few things. From the part number, it seems you are using 48-pin SSOP. As you know for 48-pin SSOP devices, P1[2] is the only pin available for XRES and you have to be careful that you dont change the functionality of that pin from XRES pin to GPIO pin. This is given as option "Use Optional XRES" in PSoC Creator cydwr file.

If you program data that disables the P1[2] as XRES, then you can program the part only by Power cycle mode. Unfortunately, the current Miniprog3 does not support Power cycle mode. Please refer the KB article  ( for details on this.

With these information, the reason for your failure might as well be that you are programming NVL data that disables P1[2] as XRES. The easiest way to find this is if you can attach your hex file used to program PSoC 3. If the information is confidential, please email hex file to (it is 2 V's and not W in email id) and I will confirm this.



dushybansi's picture
3 posts

 same error SPC polling failed....communication with the chip lost....comes when XRES pin is disconnected/not connected properly on the board or the programmer.


Thanks and Regards


user_78878863's picture
2553 posts

This problem is more than two years old. I doubt that original poster will read this...

Log in to post new comments.