You are here

New EEPROM API (3.0) | Cypress Semiconductor

New EEPROM API (3.0)

Summary: 1 Reply, Latest post by pvkv on 08 Dec 2015 02:08 AM PST
Verified Answers: 1
Last post
Log in to post new comments.
gogglygogol's picture
10 posts


I think I've got a problem with the new EEPROM 3.0 API. I used the old EEPROM API in other projects without problems:

For writing a Byte I used:     EEPROM_ByteWrite(someByte , 0x00,0x02);        

for reading a Byte I used:        someByte  =  CY_GET_REG8(CYDEV_EE_BASE + 0x02);

That worked well and everything was good.

Now I tried to use the new API:

For writing a Byte I'm using:    EEPROM_WriteByte(someByte ,3);

for reading a Byte I'm using:        someByte = EEPROM_ReadByte(3);

Sometimes this works, sometimes not...

Do I use the new EERPOM API correct? Is that correct to not use the CYDEV_EE_BASE anymore? By the way, I'm using also I2C in my Project, I have no problem with that until I'm using the EEPROM.  Or are there any timing issues between I2C and EEPROM access?

thanks a  lot


pvkv's picture
Cypress Employee
82 posts


Can you refer to EEPROM code example provided with Creator ? You can find it here. Go to PSoC Creator -> File -> Code Example

What was the EEPROM component versions when it worked and when it did not ?

Log in to post new comments.