You are here

miniprog3 suddenly failed | Cypress Semiconductor

miniprog3 suddenly failed

Summary: 2 Replies, Latest post by U2 on 18 Feb 2011 11:06 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
robertseczkowski's picture
127 posts

I have one chip connected with address 04. I can't communicate with it via I2C although I am able to program it.

During I2C session response alwas is FF-

I conclude miniprog3 failed, because I't worked with several chips in the morning, but now it don't wiht neither of them.

ALso there is a strange device listing. Can someone try listing devices connected.

Miniprog3 device listing (using List button:

Devices list:  8bit  7bit
     address:  0C    06
     address:  0E    07
     address:  1A    0D
     address:  26    13
     address:  32    19
     address:  3E    1F
     address:  4A    25
     address:  56    2B
     address:  62    31
     address:  64    32
     address:  70    38
     address:  7C    3E
     address:  7E    3F
     address:  8A    45
     address:  96    4B
     address:  A2    51
     address:  AE    57
     address:  BA    5D
     address:  BC    5E
     address:  CA    65
     address:  D6    6B
     address:  E2    71
     address:  EE    77
     address:  FA    7D


Stub for 2575603's picture
99 posts

If your MiniProg3 failed and you open a Technical Support case on the website, we should be able to get a new one sent out to you.



uday's picture
Cypress Employee
569 posts


This is not issue with MiniProg3. I have faced this issue earlier. I guess you are using Miniprog3 as USB-I2C bridge and trying to communicate with a PSoC3. The main problem here is the I2C bus connection. Due to loose contacts it is possible that the devices listed on the I2C bus are more than one. Establish a firm connection by some means(sodering ), that may fix this issue.

Log in to post new comments.