You are here

error while programming | Cypress Semiconductor

error while programming

Summary: 6 Replies, Latest post by danaaknight on 29 Apr 2013 04:49 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
user_222091147's picture
25 posts

i am using capsense on PSoC3 CY8C3245LTI-144 [Silicon ID: 0x1E090069].

while building it is not showing any warning, but at the time of programming it is showing one of the following errors.

errors are shown in attached file.

my  .cydwr page and build settings are also shown.

what kind of probiem it should be?


anir's picture
24 posts

Hi Nilesh,

                  As per the first error message it looks like the device selected for building the project is not same as that on the kit. Please check if the device selected for building the project is same as that on the kit.


Regards, Aniruddha


dasg's picture
Cypress Employee
730 posts

Hi NileshTekale,


1) Which version of PSoC3 are you using? You can find that by reading the name on the chip, which might read like CY8C3245LTI-144ES1 or CY8C3245LTI-144ES3. It is important that the device selected matches with the actual device being programmed (Including the ES1, ES2). If there is a missmatch, then choose the appropriate device from Project > Device Selector

2) Are you powering the device externally or using Miniprog3 to power the device while programming?

3) Did you try programming the device using PSoC Programmer?


user_222091147's picture
25 posts

yes the device is same.

i have connected

XRES     to   P1[2]   and also

VTARG pin of Miniprog3 to VDDIO1 of PSoC.

user_222091147's picture
25 posts

on ic es1 or es3 is not mentioned.

it has

CY8C3245LTI-144  1125

A  04   PHI.


2) no external power supply used it is given by miniprogrammer3 and it is set on 5v.

3) yes i tried psoc programmer and same error appears.

yliu's picture
Cypress Employee
38 posts

 Hi NileshTekale,

Is this problem solved? Can you share how if you remember?

I guess the most possible reason if hardware connection issue, see the other thread in below link:

Thank you,



user_14586677's picture
7646 posts

@yliu, do you think NileshTekale is still following this thread

7 months later, just a thought........


Regards, Dana.

Log in to post new comments.