You are here

Procedure first use of a Cypress CYBL10162 ? | Cypress Semiconductor

Procedure first use of a Cypress CYBL10162 ?

Summary: 2 Replies, Latest post by technique_1414796 on 29 Jul 2015 12:17 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
technique_1414796's picture
2 posts


I'm currently testing a new board prototype using exactly the same schematics as the BLE dongle key of CYPRESS (CY8CKIT-042-BLE kit).

The same firmware works fine on the CYPRESS dongle key but not on my prototype.

So, the first easy and obvious conclusion is : there is a issue on my prototype !

But, after having spent a lot of hours to check everything on my prototype :

- component CYBL10162 well soldered

- no short-circuit or open circuits on the board

- good components used

- no issue on power supplies, concerning the /XRES or clocks signals

- no difference between the layouts and schematics of the 2 boards, ...

... the result is still the same :

The CYPRESS CYBL10162 chip can be powered and be programmed without any issue but absolutely no Bluetooth link as in the dongle key (I use simple firmware files from CYPRESS, BLE applications).

Several trials have been done with different firmware files. And still the same result : it works on the dongle key but never on my prototype.



Is there any particular procedure to put in place, when we use the CYPRESS CYBL10162 for the first time ?

I think for example to an internal emulated EEPROM memory to program for example ? Or something like this ? I don't know.


Thanks for your help !

user_1377889's picture
9265 posts

Welcome in the forum.

Sorry to say, but there is no special magic to bring your PRoC to life. It must be a hardware problem.

Since you were able to program the chip, you should be able to debug it using the Miniprog3 or the Kitprog. this should usually help.



technique_1414796's picture
2 posts


Thank you for the quick reply !

You're right. In fact, I got an hardware issue with the 24 MHz crystal which was badly connected.

Now it seems to work really better .. but still no radio link. So, I continue to investigate on antenna side.


Log in to post new comments.