You are here

[SOLVED] CY8CMBR3106S - Getting No ACK | Cypress Semiconductor

[SOLVED] CY8CMBR3106S - Getting No ACK

Summary: 4 Replies, Latest post by Bob Marlowe on 15 Sep 2016 07:36 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.
Robbe Van Assche's picture
User
3 posts

Hey,

I have a PCB with the CY8CMBR3106S on. It's a low volume product (500-1k).

But, when i try to talk to the sensor via I2C, the sensor does not respond.

I understand it is in low power mode, but it never wakes up.

It has 1V8 on it's internal regulator and 3V3 on the VDD.

Seperate decoupling caps close to the VDD / CMOD.

Any solutions? I am searching almost 2 days already..
Would be a shame to not use this chip this far in my design process..

user_1377889's picture
User
9827 posts

I would suggest you to get in contact with Cypress directly: At top of this page select "Design support -> Create a Support Case" and ask your question. You will be helped by a Cypress engineer. You may provide them with schematics and/or layout, Cypress will keep those information confidential.

 

Bob

 

Robbe Van Assche's picture
User
3 posts

Thanks. I created a case. I will reply with the resolution for further reference.

Robbe Van Assche's picture
User
3 posts

I switched the SCL and SDA pins on my custom pcb. Stupid, but possible. Watch out for it.

user_1377889's picture
User
9827 posts

When you have got two wires the probability to connect them wrong is exactly 50%

I can assure you that these 50% are used up to 100%   ;-)

 

Bob

Log in to post new comments.