You are here

PSoC Designer Build Error (ilibw.exe) | Cypress Semiconductor

PSoC Designer Build Error (ilibw.exe)

Summary: 6 Replies, Latest post by k.k on 26 Nov 2016 05:14 AM PST
Verified Answers: 0
Last post
Log in to post new comments.

Hi, 
I am using PSoC Designer 5.4 SP1 on windows 10 and I amgetting an error dialog "ilibw.exe has stopped working" when I try to generate/build the project. 
The output tab shows the following information: 
Starting MAKE... 
creating project.mk 
lib/adcinc_1.asm 
lib/adcinc_1int.asm 
lib/lcd_1.asm 
lib/pga_1.asm 
lib/psocconfig.asm 
lib/psocconfigtbl.asm 
make: *** [lib/libPSoc.a] Error 255 

PDProject1 - 1 error(s) 0 warning(s) 02:57:29 

You can find the project attached to this thread. Can you please provide a solution?

user_1377889's picture
User
9572 posts

Project compiles fine although requests update for ADCINC component.

When de-install and re-install of Designer does not help, I would suggest you to get in contact with Cypress directly: At top of this page select "Design support -> Create a Support Case" and ask your question. You will be helped by a Cypress engineer.

Bob

chengjingjia_2029701's picture
User
1 post

I've met with the same problem,I tried to reinstall it,but problem still exist.

user_1377889's picture
User
9572 posts

Welcome in the forum.

Did you read and follow my previous post?

 

Bob

1) Go to the below location (location might slightly vary on your PC based on your installation folder of PSoC Designer):

C:\Program Files (x86)\Cypress\PSoC Designer\5.4\Common\CypressSemiBuildMgr\tools

 

2) Right-click on "ilibw.exe" and click on "Properties" and then go to "Compatibility" tab, and check the "Run this program in compatibility mode for" checkbox, and in the drop-down, select "Windows 7".

 

3) Open PSoC Designer and the project, and try building, and check if the issue is overcome.

If the issue still persists, repeat the same procedure, but instead of "Windows 7" select "Window XP (Service Pack 3)" in the compatibility drop-down.

This did not work for me, instead it threw a new error. Maybe you can try this solution and let me know if it worked for you. 

An alternate solution is starting windows in safe mode and building the application. Although, it is tedious, it is the only workaround I have found to this problem till now.

k.k
k.k's picture
User
1 post

This problem will be resolved by uninstalling the "symantec" product.

Log in to post new comments.