POR Warning on Build | Cypress

POR Warning on Build

Summary: 4 Replies, Latest post by Arvind Krishnan on 25 Nov 2012 11:29 PM PST
Verified Answers: 0
Last post
Log in to post new comments.
Jamesve's picture
User
3 posts

I can't find how to deal with this. Thank you for any help.

user_14586677's picture
User
7301 posts

Not sure why you are getting a warning for something you may not have set,

but look at global resources, and bump up the Trip Voltage in the global settings.

 

Regards, Dana.

user_27941315's picture
User
78 posts

Look at the TRM page 292, it gives you the information concerning the POR. According to the TRM(Technical Reference Manual) there is 3 available voltage for the POR.

 

I don't think you can get rid of this messsage since you can't set this parameter in the global resource pane.

 

Hope it helps

Jamesve's picture
User
3 posts

Yes, I originally just noted and disregarded this, ( and it was in configuration step, not build, sri) It was  a "Level 1 warning". Just thought that power on reset might be important, but not in 'main.file'.

Will check suggestions, and thanks.

Arvind Krishnan's picture
Cypress Employee
143 posts

 

According to the DC POR and LVD Specifications from a 28xxx datasheet,

 

 

I cant seem to find any options to change POR from the GUI, so I guess this warning is to let you know about the current POR setting. The 2.9 V corresponds to the default value for the POR bits in VLT_CR register, which is 00b

 

If you want to set any other POR level, you have to modify the VLT_CR value in your code.

 

 

Log in to post new comments.