You are here

Cysmart firmware version Where did it go | Cypress Semiconductor

Cysmart firmware version Where did it go

Summary: 6 Replies, Latest post by Bob Marlowe on 25 Dec 2015 03:09 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
mypitboss's picture
2 posts

CySmart refuses to load until I download firmware version   My BLE dongle (from the Pioneer kit) came with version  

When I get this error message, it directs me to "", which doesn't have any firmware.   A fresh install of CySmartSetup.exe doesn't help in any way.

Tried many searches on the Cypress site.   It all seems to lead to this frustratingly incomplete page.




user_14586677's picture
7646 posts

If you download CySmartSetup.exe, run it, and look at win driver

properties is it reporting the correct rev ? Maybe uninstall driver

and let it reinstall itself ?


Regards, Dana.

mypitboss's picture
2 posts

Thanks, Dana.   But, I don't know how to do that (not a big Windows person).   Not sure where that would take me anyway.

I'm going to guess the simplest explanation is the correct one:  the dongle needs a firmware upgrade, but they didn't post it.

grobasoz's picture
1 post

Try this... it worked for me...

Plug in your CYSmart BLE dongle.

Head over to

Download BLE Dongle CySmart.hex

Run PSOC Programmer (you should have it when you installed other PSOC tools?)

Select the KitProg/BLE0F...... dongle.

Program it :)

Restart CYSmart. It should now appear as Cypress BLE Dongle (Comxx)

Good luck! 

1 post

thanks grobasoz, worked for me as well.

maruyama-h_1538746's picture
1 post

Would you please teach us how to get CySmart 1.0?

BLE PRoC device need CySmart 1.0 (not 1.1).

user_1377889's picture
9284 posts

Maruyama, you are here in the PSoC1 forum which has nothing at all to do with BLE. Better ask your question in a (new) thread in PRoC  BLE forum.



Log in to post new comments.