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1 Welcome to PSoC Creator 

PSoC Creator helps you configure and program analog- and digital-peripheral functionality into a Cypress PSoC 
device. Using PSoC Creator, you can select and place Components, write C and/or Assembly source, and debug 
and program the project/part. When used with associated hardware, this dynamic hardware-software combination 
allows you to test the project in a hardware environment while viewing and debugging device activity in a software 
environment. 

Note This document refers to PSoC 4 devices throughout (in addition to other devices). References to PSoC 4 
should be interpreted to include PSoC 4, PSoC Analog Coprocessor, and PRoC® BLE (Bluetooth Low Energy). 

This PSoC Creator help contains the following sections: 

Getting Started Tutorials to get you started using PSoC Creator. 

Understanding PSoC Creator Information and tasks to better understand PSoC Creator. 

Using Design Entry Tools Tasks and interface descriptions for the graphical design entry tools. 

Building a PSoC Creator Project Topics for configuring and building PSoC Creator projects. 

Integrating into 3rd Party IDEs 

Information and tasks for generating PSoC Creator design files for use 
with a 3rd Party IDE 

Programming and Debugging a 
PSoC Creator Project 

Topics for programming the device and using the debugger. 

Completing the Project Topics for finalizing a PSoC Creator design. 

Reference Material 3rd party tool chain docs and other reference material. 

Revision History 
Document Title:   PSoC

®
 CreatorÊ User Guide 

Document Number: 001-93417 

Revision Date Description of Change 

** 7/17/14 New document. 

*A 7/25/14 Updates to include references to PSoC 4 BLE and PRoC BLE. 

*B 12/12/14 Updated screen captures and Design-Wide Resources section. 

*C 5/14/15 Updates for PSoC Creator 3.2 and PSoC 4100M and PSoC 4200M. 

*D 9/10/15 Updates for PSoC Creator 3.3 and PSoC 4200L. 

*E 12/30/15 Updates for PSoC 3.3 Service Pack 1. 

*F 9/9/16 Updates for PSoC Creator 4.0. 

*G 4/13/17 Updates for PSoC Creator 4.1. 
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2 Getting Started 

This section contains tutorials to help get you started using PSoC Creator.  There are two sets of tutorials: 

Â Design Tutorials - Walkthroughs to get you creating designs quickly. 

Â How To - Miscellaneous tutorials to help increase your efficiency using PSoC Creator. 

  

Design Tutorials 

This section contains the following design tutorials to help you get started creating designs with PSoC Creator. 
Code examples for these tutorials are contained in the Find Code Example dialog, available from the Start page. 
These tutorials are intended to provide quick introductions to begin using PSoC Creator. For more information, refer 
to the following 

Â PSoC 3: AN54181: www.cypress.com/go/PSoC3GettingStarted 

Â PSoC 4: AN79953: www.cypress.com/go/PSoC4GettingStarted 

Â PSoC 4 BLE: AN91267: www.cypress.com/go/AN91267 

Â PSoC 5LP: AN77759: www.cypress.com/go/PSoC5GettingStarted 

Â PRoC BLE: AN94020: www.cypress.com/go/AN94020 

Â PSoC Creator Training: www.cypress.com/go/creatorstart/creatortraining 

You may also obtain various kits to use with PSoC Creator and associated devices. When installed, these kits 
provide additional documentation and tutorials, available on the PSoC Creator Start Page. 

Beginner: 

Â My First Design "Hello World Blinky" 

Â Starter Projects 

Intermediate: 

Â Basic Design 

Â Debugging a Design 

http://www.cypress.com/go/PSoC3GettingStarted
http://www.cypress.com/go/PSoC4GettingStarted
http://www.cypress.com/go/AN91267
http://www.cypress.com/go/PSoC5GettingStarted
http://www.cypress.com/go/AN94020
http://www.cypress.com/go/creatorstart/creatortraining
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Advanced: 

Â Library Component Project 

Â Basic Hierarchical Design 

See Also: 

Â Find Code Example 

Â How To 

  

Beginner 

My First Design "Hello World Blinky" 

This tutorial provides an introduction to PSoC Creator and the process of developing a design. The design process 
includes: 

Â Create a New Project 

Â Add/Configure Components 

Â Write C Code 

Â Program the Device 

This is the first of a few design tutorials included in this PSoC Creator Help file. This design will show you how to 
blink an LED. Then you will add another Component to display "Hello World" on an LCD. 

Note If you prefer not to create a new empty project, you can open a completed code example for this tutorial, 
named "HelloWorld_Blinky," using the Find Code Example dialog. A link to the dialog is located on the PSoC 
Creator Start page. There are also several Starter Designs you can create from the New Project dialog. 

Create a New Project: 

The first step of creating a design is to create the basic design project. 

1. From the File menu, select New > Project or click  to open the New Project wizard. 

2. For Target device, select the default PSoC 3 device, or select the specific device you want to use. For this 
project, we are using the default PSoC 3 device CY8C3866AXI-040. If you select a different device, then you 
will need to adjust your pin settings accordingly. 

3. On the "Select project template" page, select Empty schematic. 

4. In Name, type the name of your project, for example: "MyHelloWorld." 

5. In Location, type the path where you want the project to be saved, or click [...] and navigate to the appropriate 
directory. 

6. Click Finish. 
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By default, PSoC Creator creates a new workspace containing the new project. Files and folders are added to the 
Workspace Explorer shown in the Source tab. 

 

The Schematic Editor displays the top-level schematic file (TopDesign.cysch) as a document window, and the 
Component Catalog opens to display a list of Components to use in your design. 

Note If you created this project in the same workspace as another project, make this the active project by selecting 
Set as Active Project from the Project menu. 
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Add/Configure Components: 

After the new project has been created, add Components to the schematic canvas and configure them as 
appropriate. 

1. In the Component Catalog, expand the "Digital > Functions" folder and drag a PWM Component onto your 
design. 

 

The Notice List window indicates that there are connection errors. 
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2. Double-click the PWM Component to open the Configure dialog, change the Implementation setting to "Fixed 
Function," and click OK 

 

Notice the Component instance's appearance changes: kill input added, one pwm output available, and the 
label is updated. 

 

3. In the Component Catalog, expand the "Digital > Logic" folder, drag a Logic Low Component onto your design, 
and connect it to the kill terminal on the PWM. Connect another Logic Low to the reset terminal. 

4. In the Component Catalog, expand the "System" folder, drag a Clock Component onto your design, and 
connect it to the clock terminal on the PWM. 
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The Notice List window clears. 

 

5. Double-click the Clock to open the Configure dialog, change the Desired Frequency value to 0.25 kHz, and 
click OK. 

 

6. In the Component Catalog, expand the "Ports and Pins" folder, drag a Digital Output Pin Component onto your 
design, and connect it to the pwm terminal on the PWM. 
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Your design should now look like the following image. 

 

Assign Pin: 

PSoC Creator will automatically assign the pin to a physical port/pin on the device. To specify a specific pin, use the 
Pin Editor. 

1. In the Workspace Explorer, double-click the HelloWorld.cydwr file to open the Design-Wide Resources Pin 
Editor. 

 

2. Pull down the menu in the Port or Pin column and assign Pin_1 to the following pin, depending on the kit you 
have: 

Ǐ For the PSoC 3 FirstTouch Starter Kit (CY8CKIT-003), use P4[1] (or pin 70). 

Ǐ For the PSoC Development Kit (CY8CKIT-001), use P0[0] (or pin 71). 

Write C Code: 

1. In the Workspace Explorer, double-click the main.c file to open it. 

2. Add the following function to main(): 

    PWM_1_Start();  
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Program the Device: 

1. Connect the MiniProg3 to your kit and plug it into your PC with a USB cable. 

2. If you are using the PSoC Development Kit (CY8CKIT-001), use a wire to connect the P0[0] pin to one of the 
four LEDs. Refer to the appropriate documentation for the kit for more information. 

3. Click Program . 

4. If the Select Debug Target dialog displays, select your device, then click Connect and OK. 

PSoC Creator will build your design, generate code, and program the device. When programming is complete, the 
selected LED on the board will blink; press the Reset button if needed. 

Expand the Design: 

If you are using the PSoC Development Kit (CY8CKIT-001), you can expand the design to display "Hello World" on 
the LCD. 

1. On the Component Catalog, expand the "Display" folder and drag a Character LCD onto your schematic. 

2. Open the Pin Editor, and assign LCD_Char_1:LCDPort to P2[6:0]. 

3. Open the main.c file, and edit it to add the following to main(): 

LCD_Char_1_Start();  

LCD_Char_1_PrintString("Hello World");  

  

4. Click Program . 

PSoC Creator will build your design, generate code, and program the device. When programming is complete, the 
LCD will display the words "Hello World." 

From this point, you can modify the design to do different things as desired. 

See Also: 

Â Code Examples 

Â Find Code Example 

Â Workspace Explorer 

Â Schematic Editor 

Â Component Catalog 

Â Pin Editor 
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Code Examples 

PSoC Creator provides several Code Example projects. These projects highlight features that are unique to PSoC 
devices. They allow you to create a design with various Components and code already provided, instead of 
creating a new empty design. 

To Use Code Example Projects: 

1. From the File menu, select New > Project or click  to open the New Project wizard. 

2. Select the appropriate Design project option and click Next >. 
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3. On the "Select project template" page, select the Code example option and click Next >. 

 

4. On the "Select a code example" page, select a project from the list. This page is very similar to the Find Code 
Example dialog. If needed, use the Filter by field to narrow the number of examples listed. Click Next >. 
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5. On the "Create Project" page, select the appropriate options. 

 

6. Click Finish. 

The selected project is created and files are displayed in the Workspace Explorer. The project is ready to build and 
program the device. For more information, refer to the documentation included with the design. If the 
documentation is not available, select the Include Starter Design documentation... option in the Options Dialog, 
and re-create the project. 

See Also: 

Â Creating a New Project 

Â Workspace Explorer 

Â My First Design "Hello World Blinky" 

Â Options Dialog 

My Templates 

My Template projects are similar to code examples and pre-populated schematic projects in that these projects 
contain various levels of information already, including device configuration, Components, Design-Wide Resources, 
etc. The main difference with My Template projects is that they are created and copied to a specific directory by you 
for later use when creating a new project. 

To Specify the My Templates Location: 

The default location for storing My Templates projects is <user>\Documents\PSoC Creator\My Templates. 
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To change this, open the Options dialog. Under Project Management, use the Browse... button to navigate to the 
desired location. 

To Copy a Project to My Templates: 

In the Workspace Explorer, under the Source tab, right-click on a design project and select Copy to My Templates 
(<project_name>). You can also use the Project menu to select the same option. 

Note When copying a project to the My Templates location, any relative project dependencies will need to be 
updated when a new project is created from it. Any referenced files outside of the project's cydsn directory will not 
be included in the new My Template project. 

To Create a Project from My Templates: 

Note When creating a project from My Templates, if the created project is of a different device family than the My 
Templates project, then the Design-Wide Resource files will no longer an applicable and a new <project>.cydwr file 
will be generated. 

After copying one or more projects to the My Templates location, follow the usual instructions to create a new 
project, except, as follows: 

1. On the Select project template step, select the My Template project option and click Next >. 
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2. Then on the Select a My Template project step, select the desired project from the list, and click Next >. 

 

3. On the final step, specify the name and location of the project/workspace as usual. 

  

Intermediate 

Basic Design 

This tutorial provides more details about configuring Components and working with Design-Wide Resources 
(DWR). It is intended to be a design focusing on a set of basic Components to show various ways of configuring 
them. This tutorial does not cover every step in the design process in great detail. Instead, it describes concepts 
relevant to parts of the design. You can then use the same principles in any design. For introductory instructions for 
creating a design, refer to the "Hello World Blinky" tutorial. 

Note If you prefer not to create a new project, you can open the completed code example for this tutorial, named 
"BasicDesign," using the Find Code Example dialog. A link to the dialog is located on the PSoC Creator Start page. 

Create a New Project: 

As shown in the "Hello World" tutorial, the first step for a design is to create a new project. As needed, follow the 
instructions in that tutorial. You can also refer to Creating a New Project. 
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Select and Configure Digital Components: 

For this tutorial, the main digital Component will be the Timer. Then, you will add support Components to your 
design, configure them, and connect them to the Timer. 

1. Expand the Digital > Functions folder in the Component Catalog, click on the Timer Component, and drag it 
onto your design canvas. 

 

Notice that the Timer is already connected to a Clock Component and a Logic Low Component. This is 
because the Timer is an example of a Schematic Macro. 

2. Remove the Clock and the Logic Low Components because this example will use different Components. 

3. Double-click the Timer Component to open the Configure dialog. 

By default, the Timer is configured as 8-bit, Fixed Function, and Software Only enable. For more information 
about the Timer Component, refer to its datasheet. 
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Change the following parameters: 

Ǐ Implementation to UDB 

Ǐ Enable Mode to "Software and Hardware" 

Ǐ select the Interrupt on TC check box 

 

4. Click OK. 

Notice that the "enable" terminal displays on the Timer. 

 

5. From the Component Catalog, add the following Components to your design: 

Ǐ Control Register (from the Digital > Registers folder) -- Used to enable the Timer under software 
control, as well as provide a reset signal for the Timer. 

Ǐ Digital Output Pin (from the Ports and Pins folder) -- Used to provide a divided clock for another 
Component in the design. The divided clock is 3.1 KHz. 

Ǐ Clock (from the System folder) -- Used to provide the input clock. In this case at 800 KHz. 

Ǐ Interrupt (from the System folder) -- Used to act as a heartbeat for the design. The heartbeat can be 
used for timing of software functions. 
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6. Configure the following Component instances as follows: 

Instance Parameter(s) 

Control_Reg_1 NumOutputs: 2 

Clock_1 Desired Frequency: 800 Khz 

7. Arrange the Components on your design, and use the Wire tool  (from the Design Elements Palette, to 
connect them, similar to the following. See Working with Wires for more information. 

 

When complete, all DRC warnings and errors should be cleared. 

Select and Configure Analog Components: 

The next part of the design will contain a Delta Sigma ADC as the main analog Component, along with support 
Components. 

1. From the Component Catalog, drag a Delta Sigma ADC Component (from the Analog > ADC folder) onto your 
design. 
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2. Double-click the Component to open the Configure dialog. 

 

By default, the Delta Sigma ADC is configured as 16-bit, with an input range of +/- 1.024 V. For more 
information about the Delta Sigma ADC Component, refer to its datasheet. 

3. Change parameters as follows: 

Ǐ Under the Common tab, set Input Mode to "Single ended." 

Ǐ Under the Config1 tab, change the Resolution parameter to "12" and Input Range parameter to 
"Vssa to Vdda". 

Ǐ Click OK. 

Notice that the label below the Component reads 12 Bit Resolution. 

 

4. From the Component Catalog, add the following Components to your design: 

Ǐ Analog Pin (from the Ports and Pins folder) -- Used to connect the input signal to the ADC. 

Ǐ Interrupt (from the System folder) -- Used to trigger reading the result of a conversion from the ADC. 
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5. Arrange the Components on your design, and use the Wire tool  (from the Design Elements Palette, to 
connect them, similar to the following: 

 

Notes 

Ǐ First, notice that the wire from the Analog Pin to the ADC is red by default, and the wire from the ADC 
to the Interrupt is green by default. PSoC Creator uses these colors to indicate analog and digital 
signals. These colors can be changed using the Options dialog. 

Ǐ Second, note that a wire is not needed to connect the Components. You can connect them directly by 
their terminals . This tutorial uses wires to show the different signal colors. 

When complete, all DRC warnings and errors should be cleared. 

Edit Source Code: 

1. Build the project to generate source files for the Components. 

When complete, the Workspace Explorer expands the Generated_Source folder to show all the c files and 
header files for the various Components in your design. 

2. Open the header files to view (and copy) the function prototypes you will enter in the main.c file. 

3. Copy and paste the following code and replace any code in your main.c file. 

Note The comments in the following code are for your information. 

  

/*******************************************************************************  

* File: main.c  

*  

* Version: 2.0  

*  

* Description:  

*   This is a basic design source code.  

*  

********************************************************************************/  

#define ADC_NUMBER_SAMPLES (15)  

     

/* Initialize array elements to zero. */  

uint16 ADC_Samples[15] = {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};  

     

/* Defining and initializing t he index */  

int8 ADC_Sample_Index = 0;  

     

/* Initiialize the average result */  

uint32 ADC_Sample_Average = 0;  

     

/* Sample read from ADC */  

int16 ADC_Current_Sample = 0;   

     

/* Indicator for when sample is available */  
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int8 ADC_Sample_Available = 0;  

/*******************************************************************************  

* Function Name: InterruptHandler  

********************************************************************************  

* Summary:  

*   The Interrupt Service Routine for isr_1.  

*  

*  Parameters:   

*   None.  

*  

* Return:  

*   void.  

*  

*******************************************************************************/  

CY_ISR(InterruptHandler)  

{  

    Timer_1_ReadStatusRegister(); /* Read the Status Register */  

}  

       

/************************ *******************************************************  

* Function Name: main  

********************************************************************************  

* Summary:  

* Main function performs following functions:  

* 1: Start the clock  

* 2: Start the Time r  

* 3: Start the interrupts  

* 4: Start ADC DelSig and its interrupts  

* 5: Testing for sample available from ADC  

* 6: Storing the sample into the array  

* 7: Comparing the samples  

*  

* Parameters:  

*  None.  

*  

* Return:  

*  None.  

*  

*******************************************************************************/ 

        

void main()  

{  

    int8 i;  

         

    CyGlobalIntEnable;  

    /* Start the Interrupt */  

    isr_1_Start();              

    isr_1_Disable();  

    isr_1_SetVector(Interr uptHandler);  

    isr_1_Enable();  

     

    /* Enable the Timer; reset disabled */  

    Control_Reg_1_Write(0x01);  

         

    /* Start the LCD */  

    LCD_Start();  

    /* Start the Timer */  

    Timer_1_Start();  

         

    /* Start the ADC */  

    ADC_DelSig_1_Start();    

         

    /* Start the ADC conversion */  
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    ADC_DelSig_1_StartConvert();  

     

    LCD_Position(0, 0);  

    LCD_PrintString("ADC OUTPUT:");  

    for(;;)  

    {  

        /* Check whether ADC conversion complete or not */  

        if (ADC_DelSig_1_IsEndConversion(ADC_DelSig_1_WAIT_FOR_RESULT))  

        {  

            /* Get the result */  

            ADC_Current_Sample = ADC_DelSig_1_GetResult16();  

            ADC_Sample_Available = 1;  

            /* Print the ADC result on LCD */  

            LCD_Position(0, 11);  

            LCD_PrintInt16(ADC_Current_Sample);  

        }  

        /* Testing for sample available from the ADC */  

        if (ADC_Sample_Available)  

        {  

            ADC_Sample_Available = 0;  

                 

            /*  storing the sample into the array, based on the index */  

            ADC_Samples[ADC_Sample_Index++] = ADC_Current_Sample;  

                 

            /* comparison */  

            if (ADC_Sample_Index == ADC_NUMBER_SAMPLES)  

            {  

                ADC_Sample_Average = 0;  

                for (i = 0; i < ADC_NUMBER_SAMPLES; i++) ADC_Sample_Average += 

ADC_Samples[i];  

                ADC_Sample_Average /= ADC_NUMBER_SAMPLES;  

                ADC_Sample_Index = 0;  

            }  

        }  

    }  

}  

/* [] END OF FILE */  

  

Build the Project: 

Click Build . PSoC Creator will build the project and display messages accordingly. Address any errors or 
warnings as needed. 

If you have a PSoC development kit with an LCD, you can click Program  to program the device and observe 
the output on the LCD. 

Next Steps: 

This tutorial contains the basic process of configuring Components in a design. To continue this design you will 
need to obtain hardware to program the device, as well as to use the debugger features. In the mean time, you can 
refer to the following related topics: 

Â Debugging a Design  
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Debugging a Design 

This tutorial will use the design created with the Basic Design tutorial and go through several debugging concepts, 
such as setting a breakpoint, adding a watch, and stepping. This design will show the values of an array at different 
points while executing the code. It will also show the total and average of the specified variable. 

Open Example Design: 

If you created a design with the Basic Design tutorial, you can use that one. Refer to Opening an Existing Project 
for instructions to open the design, as needed. 

You can also open the completed code example for this tutorial, named "BasicDesign," using the Find Code 
Example dialog. A link to the dialog is located on the PSoC Creator Start page. 

Set Breakpoints and Step: 

In this section, you will set a couple breakpoints and run the debugger to verify that the code is being executed as 
desired. You will also use the Step function to show where in the stack you are currently viewing. For more 
information about breakpoints, see Breakpoints Window. For more information about stepping, see Debugger 
Toolbar Commands. 

1. In the Workspace Explorer, double-click the main.c file to open it. 

2. Scroll to the for loop section and click in the margin of line 105 to insert a breakpoint at the line of code. 

A breakpoint indicator appears in the margin next to the desired line of code. 

 

3. Click Debug  to start the debugger. 

Depending on the Debugger Option settings, the Debugger will run to Main. 
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4. Open the Call Stack window from the Debug > Windows menu. Notice the current line indicator is in main(). 

 

5. Click Continue . 
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The Debugger will run to the breakpoint you set. Notice the current line indicator over the breakpoint icon, as 
well as in the Call Stack window. 

 

6. Click Step Into . 
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The debugger opens the ADC_DelSig_1_INT.c file and stops at line 73. Again notice the current line indicator in 
the Call Stack window. 

 

7. Stop the debugger by clicking . 

Now that you have confirmed the debugger stopped at the desired breakpoint, you can disable the breakpoint by 
right-clicking on the icon in the margin and selecting Disable. 

Set Hit Count and Variable Watchpoint: 

In this section, you will set a hit count breakpoint as well as a variable watchpoint to monitor the values of an array. 

1. Open the main.c file and scroll to line 50. 

2. Click in the margin to set a breakpoint and then right-click on the breakpoint icon and select Hit Count... 

 

The Breakpoint Hit Count window opens. 



Getting Started 

PSoCÈ CreatorÊ User Guide, Document # 001-93417 Rev *G 33 

3. Enter the hit counter number of "5" and click OK. 

4. Click Debug  to start the debugger. 

Depending on the Debugger Option settings, the Debugger will run to Main. 

5. Right-click on the ADC_Samples array in line 51 and select Add Watch. 

The Watch 1 window opens showing the ADC_Samples array. Expand the list to see all the array values. 

 

6. Click Continue . 

The debugger stops on line 50 and the Watch Window shows the ADC_Samples array with two values 
assigned. 

 

Note Breakpoints are hit twice when interrupts are enabled. This happens because the breakpoint gets hit, but 
before the line of code is actually executed an interrupt takes over and gets processed. When the interrupt has 
completed, the processor returns to the original line of code. This causes the breakpoint to be hit again. 

7. Disable the breakpoint in line 50. 

8. Add another watch to the ADC_Sample_Average in line 54 of the main.c file. 

9. Right-click in line 56, and select Run to Cursor. 
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10. In the Watch Window, notice that all the values in the ADC_Samples array now have a value and that the 
ADC_Sample_Average is the total of those values. 

 

11. Right-click in line 57, and select Run to Cursor. 

12. In the Watch Window, notice that the ADC_Sample_Average is now the average. 

 

For more information about the PSoC Creator Debugger, refer to various topics under the Using the Debugger 
section of this Help. 

Advanced 

Library Component Project 

By default, PSoC Creator provides a library of Components that are available for you to use in your designs. There 
may be cases where you wish to create your own libraries. This tutorial covers the basic process for creating a 
library by showing you how to create a 4-bit shifter. This is only an example intended to show you how to create 
basic Components. For more detailed instructions about creating Components, refer to the Component Author 
Guide. 

Note If you prefer not to create a new project, you can open the completed code example for this tutorial, named 
"LibraryComponent," using the Find Code Example dialog. A link to the dialog is located on the PSoC Creator Start 
page. Once open, select the Components tab in the Workspace Explorer to view the Component files. 

Create a New Project: 

The first step is to create the basic library project: 

1. If there is currently an open project or workspace, select Close Workspace  from the File menu. 
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2. From the File menu, select New > Project or click  to open the New Project wizard. Select the Library 
option and click Next >. 

3. In Name, type the name of your project, for example: "My1stLib." 

4. In Location, type the path where you want the project to be saved, or click [...] and navigate to the appropriate 
directory. 

5. Click Finish. 

PSoC Creator creates your project and adds files and folders to the Workspace Explorer with the Source tab 
displayed by default. For more information, see Workspace Explorer. 
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Add a Shifter Component: 

The basic library item is a Component. In order to add a Component, you must first add a Symbol, since every 
Component must have one and only one symbol: 

1. Click on the Components tab of the Workspace Explorer. 

 

2. Right-click on the project in the Workspace Explorer and select Add Component Item... 
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The Add Component Item dialog displays. 

 

3. Under Symbol, click the Symbol Wizard template file.  

4. In Component name, type the name to be displayed for your Component, for example: "shifter." 

Note The symbol will inherit the Component name, and the name cannot contain spaces. 

5. Click Create New. 
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The Symbol Creation Wizard displays. 

 

6. Using the Terminal name and Type fields in the table, create two input terminals named Data_In and Clock, 
respectively, and four digital output terminals named D0 through D3. 

 
































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































