USB problem in CY8CKIT-050 - Cypress.com Forums http://www.cypress.com/? Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=66051 OH sorry bob i didnt notice the date

Thanks otherwise ill not notice the date

 

]]>
Fri, 13 Jul 2012 06:30:45 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=66047 @sachinbvp

This thread is a quater of a year old, have a look at the last posting-dates. If we couldn't help him in those days, he would have probably gone back using SN74xxN. Yes, the times are a-changing...

 

Bob

]]>
Fri, 13 Jul 2012 05:52:08 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=66036 it seems that you are facing issues on software side and and uninstall psoc creator and driver for PSoC with any uninstaller program and go for installation again and try any project.i think this will sort out your problem

]]>
Fri, 13 Jul 2012 05:01:26 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=61382 Did you try one of the example projects (the USBFS-HID example is useful, since it doesn't need anything except the *.inf-file on the PC)? Do they work?

One of the pitfalls is to get the voltages right. The USBFS-HID project specifies, in the code, a 3.3V supply voltage, so you need to make sure that the project setting (open the USBFS_HID.cywdr file, go to the 'System' tab, open 'Operating Conditions') and the jumpers on the board match to that (or you change the code to use 5 volts).

]]>
Tue, 03 Apr 2012 06:45:00 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=60501 Has problem sorted out? If yes, please let me know how to do it

I got similiar problem with CY8CKIT-001 + CY8CKIT-010.

Many thanks

Qingshan

]]>
Thu, 15 Mar 2012 09:47:02 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=60308 Yup,sure looks like a case of messed up drivers.

]]>
Mon, 12 Mar 2012 01:48:32 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=60303  Is your issue resolved ?

]]>
Mon, 12 Mar 2012 01:06:21 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59847 I raised a CRM case, thanks.

The Windows 7 does not recognize the USB product.

]]>
Tue, 28 Feb 2012 23:37:19 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59828  If the device is connected to a Windows 7 machine, it will search for a driver and if driver is not found the OS wont notify that you anything. If you go to device manager, you will find a device with no driver installed. I hope this not happening at your end. I would suggest you to raise CRM request at the sametime to get priority support on this one. You can raise a case here, 

 

http://www.cypress.com/MyAccount/?id=25&techSupport=1&source=headers

]]>
Tue, 28 Feb 2012 06:49:55 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59821 Tried 2 different USB cables on two different machines (one running VMWare/OSX and one running pure windows).

Same problem persists, I'm able to program the device with both cables, so presumabely those work fine.

 

Thanks,

]]>
Tue, 28 Feb 2012 05:47:26 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59805 Your code gets stuck at GetConfiguration() because, no valid configuration has been assigned to your USB device. And since your device is not at all recognisd by PC, I suspect the hardware on the board and the cable. Lets eliminate one of the possible cause, could you try using a different USB cable ?

Even if with a different cable the problem continues to exist, you might have to check the connections from Pin P15[6] and P15[7] to the USB connector. 

If all this fine and still the problem continues , it could be something to do with the pull up resistors internal to the device.

Yes, I used your original project wihtout any chages, with the same clock configuration.

]]>
Tue, 28 Feb 2012 00:26:48 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59774 The project hangs on GetConfiguration(), it does not identify itself to the PC so there is no driver asked for.

It does not get to the point of identifying itself to the PC. I assume you used the same clock setting as in the project I sent?

 

]]>
Mon, 27 Feb 2012 07:09:42 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59759 I tested the project you sent on a CY8CKIT-050 and I did not see any issues at all. It worked at the first go. 

Lets start debugging this. 

  1. First thing, is your device being identified by the PC as USBUART example project, when you plug it in?
  2. Did you install the UASBUART driver ? Select the USB_UART.inf file from the project directory, as the driver for this example, once Windows asks for it.

 

]]>
Mon, 27 Feb 2012 01:52:58 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59736 Any news on this? This is really holding up the development.

]]>
Sun, 26 Feb 2012 08:49:45 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59516 Let me try out the project on a 050 kit w crystal and get back to you.

]]>
Mon, 20 Feb 2012 11:18:29 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59490 They're set to 3V and the code still hangs at the GetConfiguration() statement.

This also happens when I try to set it to 5V.

]]>
Mon, 20 Feb 2012 01:46:59 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59484  I took a look at your project and I see that USB component is coded to operate at 3V,

    USBUART_1_Start(0, USBUART_1_3V_OPERATION);

Please make sure that your regulators on the 050 kit is set to operate at 3.3V. 

]]>
Mon, 20 Feb 2012 00:32:06 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59422 guy.ron.at.gmail.com

]]>
Fri, 17 Feb 2012 08:46:03 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59416  Can you post email id here. I shall shoot an email to your email id and then you can reply.

]]>
Fri, 17 Feb 2012 04:43:16 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59415 I can't seem to be able to attach the file.

Is there an email I can send it to?

]]>
Fri, 17 Feb 2012 04:23:54 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59414 Trying to attach the project now

]]>
Fri, 17 Feb 2012 04:22:34 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59413 Project attached, essentially the USB_UART demo.

I am initiallizing globla interrupts prior to calling GetConfiguration.

Also, not sure if it matters, but I"m running this on a mac under VMWARE.

 

Thanks

]]>
Fri, 17 Feb 2012 04:21:12 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59406  One common mistake I have seen with many USB designs is, calling the USBFS_Start() API before thr global interrupt is enabled. If that is done, your chip will be stuck in an infinite loop waiting for the device to enumerate but the fact that interrupts are not enabled does not let enumeration to complete.

]]>
Fri, 17 Feb 2012 02:26:23 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59405 Please upload one of your USB projects for us to see. We will try to isolate the issue first. First could take a look at the firmware and project to see if everything is fine.

]]>
Fri, 17 Feb 2012 02:24:37 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59400 Yes, the kit works fine with an XTAL.

I can use the LCD, make a LED flash, basically do everything other than cause the USB to enumerate.

 

Thanks

]]>
Thu, 16 Feb 2012 23:49:06 -0600
Re: USB problem in CY8CKIT-050 http://www.cypress.com/?rID=59369 Does the kit operate normally with XTAL when you flash it with normal project, may be a LED blink project ?

]]>
Thu, 16 Feb 2012 06:12:47 -0600