Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. - Cypress.com Forums http://www.cypress.com/? Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=97414 Thank you for keeping us informed!

 

Bob

]]>
Thu, 10 Jul 2014 14:55:19 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=97410 Bob,

thanks for reply!  I had made an other approach which solved the problem….

In my first setup I modified the component to my own requirements and build and save it. After importing the module in my project and building it, I had that specific error.

Now I first have made a new ‘my_component’ based on the component from the Cy catalog without any mods, built it and imported it in my project. Building the project and NO errors!

Next step was to add step by step my new API’s in this component and every time I did a new build of the project and still no errors (beside some typing errors ;-).

Conclusion: there was something wrong with my first modified component but don’t know what…. 

But problem solved!

Next step is to get some lines and color on my TFT display, and that is not the case at this moment. So I have still something to figure out. Maybe I have to check the signals with my scope.

Regards,

Rob

]]>
Thu, 10 Jul 2014 14:11:23 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=97367 It HAS to do with the linker. When you look at the "output" tab you see an errormessage from "ld" which indeed is the linker. But I cannot say more. Better you create a "MyCase". (At top of this page: Support&Community -> Technical Support)

 

Bob

]]>
Wed, 09 Jul 2014 08:54:09 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=97366 Addition info...

 

when I remove calls to the module from main.c (e.g.  TFTIntf_1_Start();)

the problem is over....

Maybe it has somthing to do with linking of the module source?

Rob

]]>
Wed, 09 Jul 2014 08:47:57 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=97365 Hi,

I'm strugling also with this error....  Let me tell you what I did:

- I import and changed the Graphic LCD module as described in the PSoC-Today video.

- Saved it in the Default/MyComponents/  catalog and build the module. No problems.

- I archived the module for using it in my project

- I opened a new test project and via the Components tab, I imported the archived module

- In the Source tab I added the component in TopDesign using the component from the Default/MyComponents catalog

- Added I/O pins to the component in TopDesign and assigned pins to the pins I had allocated for this in my hardware

- Build the project and solved some minor errors

- Build again and the only error what was leftt was the one in the Title.

I did this job with other modified modules and no problem when I used them in my projects....  But this one cost me days of searching before I make this help message....

I hope anyone can give me the right hint!

I added the test project.

Rob

]]>
Wed, 09 Jul 2014 08:31:27 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57628 You can view the errors, notes and warnings by selecting the "Notice List" tab.

It gives a list of all the errors and warnings. The snapshot below shows the notice list of the project uploaded.

 

]]>
Wed, 28 Dec 2011 10:32:03 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57624 Yes DASg, teh error was due to the initialisation of the 'extern' keyword. And teh error comes as

 

 'arm-none-eabi-gcc.exe' failed with exit code '1'.

 

with no reference. That is what was making it dificult but i had to go through the whole program and initialied the extern kewyword in main.c instead of the RGBSensor.c file. Much appreciated.

]]>
Wed, 28 Dec 2011 08:26:25 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57621 Hey Maduna,

 

Good to hear that!

Was the error you were getting initially due to improper initialization of the variables using "extern"?

]]>
Wed, 28 Dec 2011 05:09:23 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57619 You are welcome!

Bob

]]>
Wed, 28 Dec 2011 04:10:26 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57618 I have managed to solve teh issues i had. Its running well now. Thanks for the efforts.

]]>
Wed, 28 Dec 2011 04:07:12 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57614 The project which Maduna is referring to is attached along with this comment.

]]>
Wed, 28 Dec 2011 02:03:12 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57579 Hi Malvin,

when I compile your project (Creator 2.0), I get

7 Errors,

9 Warnings and

2 Notes.

On the very bottom line (maybe hidden by the task-list at your desktop?) on the right-hand corner are the counts listed for errors, warning and notes. When you click at one of them, the window changes from "output" to "Notice" and you can see all your errors.

You may click as well to one of the tabs of the notice-window to hide or show the errors, notes or warnings. Since you did not see any of those (only in the output-window the error-message of the failed compile) I suppose that it is hidden from your sight by the task-bar or something similar.

Search for the bottom-line of the >Creator-Window.

Bob

]]>
Tue, 27 Dec 2011 10:19:38 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57572 Bob or DASG could you send me an email on madunaski@yahoo.com then i can send it through to you because i'm still failing to upload the file. I have reduced it to 600Kb but still failing to upload. Then you can upload it from your side.

 

 

]]>
Tue, 27 Dec 2011 06:21:24 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57566 I'd suggest that DASG or someone gives me their email and i send it to them and tehy can upload the the project because i have been trying to do this for about 4hours and i'm failing. Is that ok

]]>
Tue, 27 Dec 2011 05:26:27 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57563 Its still failing to load. i'll keep trying....

]]>
Tue, 27 Dec 2011 05:10:40 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57557 and make a "Clear" before, it reduces the size as well.

Bob

 

]]>
Tue, 27 Dec 2011 03:31:56 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57548 Hi Maduna,

 

Please use "Minimal Archive" to archive the project.

Following is the procedure:

1) Right click on the Workspace and select "Archive Workspace/Project"

2) In the Archiver window, select "Minimal". 

 

In this method, the Creator generated files will not archived thereby reducing the file size.

]]>
Tue, 27 Dec 2011 02:53:18 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57547 What is the maximum size i can upload? I have compressed it to 3.25MB

]]>
Tue, 27 Dec 2011 02:31:31 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57545 I'm having a problem uploading my zipped code. it goes on forever . any tip

]]>
Tue, 27 Dec 2011 02:21:41 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57544 Yes,go on and upload. We'll have a look at it.

Bob

]]>
Tue, 27 Dec 2011 01:56:49 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57543 I did not get any other error from teh screen after the build. I only obtained the

 

 Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

 

let me upload the zipped program and check it for me on your side and i'll give a bried xplanation of what im trying to read out

]]>
Tue, 27 Dec 2011 01:48:18 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57542 The Build Configuration/Toolchain did not yeild any positive response.

]]>
Tue, 27 Dec 2011 01:46:04 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57200 This error-message is, afaik, the last message in a row, saying that the compilation was aborted due to one or more compilation error(s). Check messages before (above) this one.

 

Hope it helps

Bob 

]]>
Mon, 19 Dec 2011 05:47:32 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57196  did you get any error or warning on the output section while building the project?  You can upload the project for people here to check.

]]>
Mon, 19 Dec 2011 03:56:03 -0600
Re: Error code 'arm-none-eabi-gcc.exe' failed with exit code '1'. http://www.cypress.com/?rID=57194 Hi Maduna,

 

Right click near the menu bars and enable the "Build Configuration/Toolchain".

Let us know if this helps.

 

If you upload the project, we can test if there is any specific issue causing this error.

]]>
Mon, 19 Dec 2011 03:37:18 -0600