You are here

AN69133 - PSoC® 3 / PSoC 5LP Easy Waveform Generation with the WaveDAC8 Component | Cypress Semiconductor

AN69133 - PSoC® 3 / PSoC 5LP Easy Waveform Generation with the WaveDAC8 Component

Last Updated: 
Nov 03, 2017
Version: 
*F

AN69133 describes how the WaveDAC8 Component works and how to use it to generate either predefined or custom waveforms. The WaveDAC8 uses DMA to generate continuous waveforms that require no CPU overhead. Several example projects are included to show simple waveform generation, frequency shift keying (FSK) modulation, and DTMF tone generation with minimal hardware and user code.

The WaveDAC8 uses DMA to generate continuous waveforms that require no CPU overhead. Several example projects are included to show simple waveform generation, frequency shift keying (FSK) modulation, and DTMF tone generation with minimal hardware and user code.

The video below is a brief overview of the application note and the WaveDAC8 PSoC Creator component.

The following table indicates the PSoC devices, PSoC Creator versions, compilers, and development kits that will work with this application note project:

Project
Device
PSoC Creator
Version
Development Kit
CY8CKIT-xxx
Compiler
Architecture
Silicon
Revision
V2.1 SP1
or higher
V2.1/2.0
001
DVK
030/050
DVK
003/014
FTK
Keil
GCC
RVDS
MDK

AN69133.zip

Prod
YES
NO
YES
YES*
NO
YES
N/A
N/A
N/A
Prod
YES
NO
YES
YES*
NO
N/A
YES
YES
YES
AN69133_Archive.zip
ES2, ES3, Prod
NO
YES
YES
YES*
NO
YES
N/A
N/A
N/A
ES1, Prod
NO
YES
YES
YES*
NO
N/A
YES
YES
YES

*Refer to Migrating CY8CKIT-001 DVK project to CY8CKIT 030/ 050.

Notes:
  1. For PSoC 5 project and related document, please download file AN69133_Archive.zip.

Projects associated with this application note can be downloaded from the ‘Related Files’ section below. For your convenience, we have provided projects that are compatible with the two most recent versions of PSoC Creator:

  • AN69133.zip is used with PSoC Creator 2.1 SP1
  • AN69133_Archive.zip is used with PSoC Creator 2.1/2.0

The project’s default settings may not be compatible with your device or kit, and you may need to change your project settings. For more information, see: